Arquivo de etiquetas: alojamento partilhado

Actualização para PHP 5.4

No seguimento de um risco de segurança optámos pela actualização no alojamento partilhado do PHP 5.3 para 5.4.x, versão que agora vamos seguir.

Existem algumas (poucas) incompatibilidades que podem ser consultadas neste documento:
http://php.net/manual/en/migration54.incompatible.php

Todas as versões mais recentes de software popular em PHP (WordPress, Drupal, Joomla, Prestashop, etc) trabalham na perfeição com esta versão e não deverá existir nenhum problema.

Em caso de software e desenvolvimentos in-house destacamos particularmente a mudança nas funções htmlentities e htmlspecialchars de por omissão aceitarem e trabalharem em UTF-8, ao passar algo que não seja codificado em UTF-8 simplesmente retornam vazio. Poderá passar a codificação utilizada como parâmetro ou a conversão do site/base de dados para UTF-8.